Author Topic: [CHRISTMAS] Willy xmas  (Read 9624 times)

0 Members and 1 Guest are viewing this topic.

Offline Buckethead

  • C= 64
  • **
  • Posts: 58
  • Karma: 30
    • View Profile
[CHRISTMAS] Willy xmas
« on: December 20, 2007 »
I made some dirty job/messy code but did my best to make things works. I'm also happy to show something for the first time to demo sceners. In my heart everything stayed like in 1987 when I saw a Replicants intro on my Atari 520 STf. (I wish I was a demo scenerâ„¢ feeling since so many years. Maybe one day...)
I was planning to work on this even being like this :crutches: hehe, until the limit but I had a problem today which had ruined my desire of competition. (a bug on a game that put me in a very sucky situation)

But hey it's J-1, christmas compo!! :xmas:
Have fun with my little Willy (he's my man, since I'd an Amstrad CPC in 1986 ;p)
Challenge Trophies Won:

Offline Voltage

  • Professor
  • Pentium
  • *****
  • Posts: 857
  • Karma: 53
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #1 on: December 20, 2007 »
wow!  It has all the stuff I like and none of the stuff I don't.

Nice feel to it as well.  I really like the reflective sphere.  Very nice first intro.  :)
Challenge Trophies Won:

Offline Maxx

  • C= 64
  • **
  • Posts: 57
  • Karma: 12
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #2 on: December 20, 2007 »
Very nice and runs nice and smoothe too well done  :goodpost:
Proud Member Of Dawn Creations
Challenge Trophies Won:

Offline Pixel_Outlaw

  • Pentium
  • *****
  • Posts: 1382
  • Karma: 83
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #3 on: December 20, 2007 »
Sadly it just crashes in windows Vista. The graphics call attempts to create a window then crashes shortly thereafter. I tried to run the demo in XP compatability mode too but nothing helped.
Challenge Trophies Won:

Offline Dr.Death

  • Senior Member
  • Amiga 1200
  • ********
  • Posts: 433
  • Karma: 8
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #4 on: December 20, 2007 »
A really cool xmas intro m8 i like it a lot  :goodpost:
Proud member of DAWN

Offline Buckethead

  • C= 64
  • **
  • Posts: 58
  • Karma: 30
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #5 on: December 20, 2007 »
Thanks a lot, I'm glad you liked it and it run cool for you!  :carrot:

Pixel_Outlaw: It could be something in the code, but there's a problem yet, I just read that v2m synth static lib could crash under vista. Luckily Energy put a comment with Magic_h2001's fix for VISTA. I will add two versions, with and without sound to be sure it's not the only problem. Should be updated soon!
Challenge Trophies Won:

Offline ninogenio

  • Pentium
  • *****
  • Posts: 1666
  • Karma: 133
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #6 on: December 20, 2007 »
this rocks!!

i really like the atmosphere in it buckethead, really really great stuff!  :clap:
Challenge Trophies Won:

Offline Buckethead

  • C= 64
  • **
  • Posts: 58
  • Karma: 30
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #7 on: December 20, 2007 »
Thanks Ninogenio ;D

In my attempt to correct the bug I've a gap in the tune, I'll study the problem. (I can only play a bit with Cubase, I forgot everything with soundtrackers.)
Yet if it runs under Window vista, even without sound it's something ;P
Challenge Trophies Won:

Offline Shockwave

  • good/evil
  • Founder Member
  • DBF Aficionado
  • ********
  • Posts: 17375
  • Karma: 497
  • evil/good
    • View Profile
    • My Homepage
Re: [CHRISTMAS] Willy xmas
« Reply #8 on: December 20, 2007 »
The screen shot looks fantastic, the music sounds excellent too but sadly it won't run properly here, it didn't make any difference what version I tried so I don't think it's the sound that's the problem it seems like the program is falling back to software rendering for something.

Anyway I will try it on my laptop tonight too :)

The gfx card here is Radeon X1650, latest drivers.
Shockwave ^ Codigos
Challenge Trophies Won:

Offline DrewPee

  • I Toast Therefore I am
  • Pentium
  • *****
  • Posts: 563
  • Karma: 25
  • Eat Cheese - It's good for you!
    • View Profile
    • Retro Computer Museum
Re: [CHRISTMAS] Willy xmas
« Reply #9 on: December 20, 2007 »
Same here matey - I can't get it to work on my laptop (which runs vista!!).
Had a quick look at the screen shot and it looks most impressive.

Hope you can get it working on Vista so that I can have a looksee!!

All the best

Drew
DrewPee
aka Falcon of The Lost Boyz (Amiga)
Ex-Amiga Coder and Graphic Designer
Administrator of > www.retrocomputermuseum.co.uk

Offline taj

  • Bytes hurt
  • DBF Aficionado
  • ******
  • Posts: 4810
  • Karma: 189
  • Scene there, done that.
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #10 on: December 21, 2007 »
I suspect it uses Nvidia only features either inmain code or shaders. Anyway runs at 1 frame a minute here. x1850
Challenge Trophies Won:

Offline Tetra

  • DBF Aficionado
  • ******
  • Posts: 2532
  • Karma: 83
  • Pirate Monkey!
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #11 on: December 21, 2007 »
Worked fine for me ;D

Really nicely done indeed, really effective use of the style you went for!
Challenge Trophies Won:

Offline taj

  • Bytes hurt
  • DBF Aficionado
  • ******
  • Posts: 4810
  • Karma: 189
  • Scene there, done that.
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #12 on: December 21, 2007 »
Worked fine for me ;D

Really nicely done indeed, really effective use of the style you went for!


Yeeeeeeeessssss soooo, do you have Nvidia or ATi?
Challenge Trophies Won:

Offline Voltage

  • Professor
  • Pentium
  • *****
  • Posts: 857
  • Karma: 53
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #13 on: December 21, 2007 »
I 'ave nvidia.  Worked beautifully. 
Challenge Trophies Won:

Offline DeXtr0

  • C= 64
  • **
  • Posts: 79
  • Karma: 4
  • Proud member of dAWN
    • View Profile
    • dAWN Creations
Re: [CHRISTMAS] Willy xmas
« Reply #14 on: December 21, 2007 »
I got the same problem as mentionned before.
It does not run on my Vista (but if I check the screenshot, it looks very very cool !)

Super idea I think.

DeXtr0

Offline Buckethead

  • C= 64
  • **
  • Posts: 58
  • Karma: 30
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #15 on: December 21, 2007 »
I've a (very) little idea to fix the problems, I'll try as soon as I can (if).
So, in the worse case, that version of the demo without sound doesn't work under Windows Vista and/or an ATI graphic card.
I think it could be the way I open the window or how I did the texture routine, the demo is pretty standard OpenGL 1.1, I didn't call any GL extension.

Sorry for that, and thanks for that great feedback.
« Last Edit: December 21, 2007 by Buckethead »
Challenge Trophies Won:

Offline Rbz

  • Founder Member
  • DBF Aficionado
  • ********
  • Posts: 2715
  • Karma: 484
    • View Profile
    • http://www.rbraz.com/
Re: [CHRISTMAS] Willy xmas
« Reply #16 on: December 21, 2007 »
Really good entry, works fine for me (GeForce 6600GT)  :clap:


Quote
I think it could be the way I open the window or how I did the texture routine, the demo is pretty standard OpenGL 1.1
If you are using only Ogl 1.1 standard, it might be a texture problem, are you using non power of 2 texture ? Because for ATI card you must use only power of 2 textures. Hope that help.
Challenge Trophies Won:

Offline Buckethead

  • C= 64
  • **
  • Posts: 58
  • Karma: 30
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #17 on: December 21, 2007 »
If you are using only Ogl 1.1 standard, it might be a texture problem, are you using non power of 2 texture ? Because for ATI card you must use only power of 2 textures. Hope that help.


Wow that help a lot :goodpost:
It's maybe not the only problem, I don't know if the version for Windows Vista without sound I put works on a Nvidia gfx card.
But it should run on more machines with power of two textures ! The sphere is mapped with the whole screen, the same with the filter, some kind of radial blur. The demo doesn't change the resolution, it's a maximized window, and nobody got 800*800 1024*1024. Now I think of it I wonder how I will fix the problem, I'll to study that. Many thanks Rbraz !
« Last Edit: December 21, 2007 by Buckethead »
Challenge Trophies Won:

Offline Jim

  • Founder Member
  • DBF Aficionado
  • ********
  • Posts: 5301
  • Karma: 402
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #18 on: December 22, 2007 »
Wow!  Lovely demo!  I like the circle-twist with cubes, even though it's hard to read :)
Is this original music?  If so great job!

I ran it on Vista with a 8600GT and music and apart from the chop in the music it's fine.
I ran it on Vista with a X1600 and none of the versions work.

Jim
Challenge Trophies Won:

Offline Buckethead

  • C= 64
  • **
  • Posts: 58
  • Karma: 30
    • View Profile
Re: [CHRISTMAS] Willy xmas
« Reply #19 on: December 22, 2007 »
Thx Jim, now it's clear to me, I know a bit more what I must set for Vista and ATI.
I'm glad you like my little tune :)
Challenge Trophies Won: