Author Topic: Demo Test  (Read 7473 times)

0 Members and 1 Guest are viewing this topic.

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Demo Test
« on: May 10, 2016 »
Hi,

i'm coding a new Demo. trying to get GLSL  correctly running. and checking out how i can add some text and other things in front of a glsl screen

here is a first preview
have fun

EDIT: [a quick & dirty new compilation]
had no time for detailed output, but maybe it is solved yet?
exe compilation updated
« Last Edit: May 13, 2016 by inc. »
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline spitfire

  • Amiga 1200
  • ****
  • Posts: 272
  • Karma: 9
    • View Profile
Re: Demo Test
« Reply #1 on: May 10, 2016 »
Screenshot looks cool but I only get a black window on my nvidia quatro k620m. But lets face it, its not the best card :P

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #2 on: May 10, 2016 »
hm. i have the Nvidia gtx 950. works smoove. Tested with Windows 7 64 bit and Windows 7 32 bit and here we have a Nvidia gts 250.
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline Kirl

  • Senior Member
  • Pentium
  • ********
  • Posts: 1200
  • Karma: 230
    • View Profile
    • Homepage
Re: Demo Test
« Reply #3 on: May 10, 2016 »
Looking cool already!  :clap:
www.kirl.nl
Challenge Trophies Won:

Offline Dr.Death

  • Senior Member
  • Amiga 1200
  • ********
  • Posts: 435
  • Karma: 8
    • View Profile
Re: Demo Test
« Reply #4 on: May 11, 2016 »
Sorry mate i only get a black window too
Proud member of DAWN

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #5 on: May 11, 2016 »
uh. strange.
is some one able to run this exe properly?
i have no problems with it at all
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline va!n

  • Pentium
  • *****
  • Posts: 1412
  • Karma: 108
    • View Profile
    • http://www.secretly.de
Re: Demo Test
« Reply #6 on: May 12, 2016 »
Amazing and very cool Demo Test you did there!
I really like the scene and the music! Cant wait for final version   :clap:
- hp EliteBook 8540p, 4 GB RAM, Windows 8.1 x64
- Asus P5Q, Intel Q8200, 6 GB DDR2, Radeon 4870, Windows 8.1 x64
http://www.secretly.de
Challenge Trophies Won:

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #7 on: May 12, 2016 »
great. thank you very much. the final will be a multi Part Demo with different shaders and some 3D stuff.
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline Rbz

  • Founder Member
  • DBF Aficionado
  • ********
  • Posts: 2723
  • Karma: 485
    • View Profile
    • http://www.rbraz.com/
Re: Demo Test
« Reply #8 on: May 12, 2016 »
Sorry mate, not working here also.
Try to add some shader info log (glGetShaderInfoLog) to your program and maybe we can help you to fix it.

My specs:
OpenGL Vendor: Intel
OpenGL Renderer: Intel(R) HD Graphics 4600
OpenGL Version: 4.3.0 - Build 20.19.15.4331
GLSL Version: 4.30 - Build 20.19.15.4331
Challenge Trophies Won:

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #9 on: May 13, 2016 »
Sorry mate, not working here also.

Oh, this is going insane. Yes i'll add more specific Code. Thanks for your feedback.
i changed quickly a few lines. maybe this solved the black screen?
pls try the new exe
thanks
« Last Edit: May 13, 2016 by inc. »
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline spitfire

  • Amiga 1200
  • ****
  • Posts: 272
  • Karma: 9
    • View Profile
Re: Demo Test
« Reply #10 on: May 13, 2016 »
Still black here.

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #11 on: May 13, 2016 »
ok. thanks. i'll take more time, to find what's going on.
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline hellfire

  • Sponsor
  • Pentium
  • *******
  • Posts: 1289
  • Karma: 466
    • View Profile
    • my stuff
Re: Demo Test
« Reply #12 on: May 16, 2016 »
Works fine here and looks cool. Nvidia GTX 970 and Win10 64Bit.
Challenge Trophies Won:

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #13 on: May 16, 2016 »
Works fine here and looks cool. Nvidia GTX 970 and Win10 64Bit.
thank you. i appreciate your comment mate :kewl:
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline emook

  • C= 64
  • **
  • Posts: 88
  • Karma: 12
    • View Profile
Re: Demo Test
« Reply #14 on: May 19, 2016 »
Hi inc

Is this based on code you got from the PB forums? If so I never had any luck with anyone being able to tell me how to gel together shaders and sprites.

PS have a look where I got too...
« Last Edit: May 19, 2016 by emook »
----

R Tape loading error, 0:1

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #15 on: May 19, 2016 »
Hi,
this Demo is a first test and preview how's working on different windowz PC and was written by me. But you 're right, many code is out there. And this is fine. The Purebasic community is open to share knowledge and useful Sourcecode. Without, I wouldn't be at this point, who am i today. I'll have a look to your attachment later today. Not online with a windowze. If i understand you right,  you have trouble to add sprites onto a glsl screen. It is possible. That's the work i do at the Moment. Adding 3D objects,  some Text and different music + shaders. The final Demo will be a multipart showcase.  when i have news, i'll leave a message here.
One question:
are you able, running my exe successful? Some buddies only see a Black screen. But i must excuse,  the code is Not cleaned yet. I'm on it.
Reply - later today.
Best
Inc
« Last Edit: May 20, 2016 by inc. »
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #16 on: May 19, 2016 »
PS have a look where I got too...

not working, bass.dll is missing
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline emook

  • C= 64
  • **
  • Posts: 88
  • Karma: 12
    • View Profile
Re: Demo Test
« Reply #17 on: May 30, 2016 »
just add bass.dll
----

R Tape loading error, 0:1

Offline inc.

  • Contact me @ skype: a5recordings
  • Amiga 1200
  • ****
  • Posts: 261
  • Karma: 19
  • I SPEAK ENGLISH & GERMAN as good as i can :D
    • View Profile
Re: Demo Test
« Reply #18 on: June 06, 2016 »
thanks. i tried to run your demo, music is playing fine but all i see is a black fullscreen.
can you change the output to window mode? i have problems to view demos in fullscreen because i have 3 tft pluged onto my pc.

edit
i see a file was written next to your demo:
metalskyle.glsl but it's 0kb
the shader is empty
« Last Edit: June 06, 2016 by inc. »
currently coding in PureBasic: GLSL Shader Maker & Editor Tool for further Demo coding usage

Offline emook

  • C= 64
  • **
  • Posts: 88
  • Karma: 12
    • View Profile
Re: Demo Test
« Reply #19 on: December 03, 2016 »
I've uploaded all the required files and sources (I think!)

----

R Tape loading error, 0:1